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the end color of the gradient (brown in our example). You can adjust the position of 
these indicators to control the blending and direction of the gradient. 

 

 

Final result 
 

In our example, the gradient starts with brown on the bottom (empty circle) and 
ends with green on the top of the hill (filled circle). The angle tilts slightly toward the 
left as shown below. 

Choose the File > Save As... command from the menu and save the project under 
the name   

 
In  1.3: Drawing Complex  on page 13  
continue working on this scene by adding more complex 

shapes. 
 
 

Tutorial 1.3: Drawing Complex Shapes 
This tutorial follows on the previous one, and teaches you how to draw more 
complex shapes. You can either continue with the project you created in Tutorial  
1.2, or you can open a file provided for you named  This file can be 
found in the -  within your custom content folder. The file 

 starting this tutorial with should look something like the following: 

(Tutorial 1.3 begins on the next page.)

(See next page.)
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Starting point 
 

Creating a New Layer 
Click the New Layer button in the Layer window to create a new layer. In the popup 
menu that appears, choose  

 

 

Create a Vector layer 
 

You can assign the name  to the new layer when you create it, or double- 
click this new layer and rename it  in the Layer Settings dialog. 

 

 

Rename the layer Clouds 
 

  Now select the Add Point tool. 

Click the Reset button in the Style panel to reset the colors to their default. 
Set the line width to 1. 
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Reset colors and set line width to 1 
 

Click to set the start point for a new line segment. Without releasing the mouse, drag 
the cursor and release the mouse to create the end of the segment. The finished 
segment is shown below. 

 

 

Add a line segment 
 

Next, click on the end of the new line segment and drag to stretch the curve out like 
this: 
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Add another segment to the end of the curve 
 

Do this a few more times until you have the curve below: 
 

 

Several more segments added 
 

The key point to remember is in order to extend a curve, you need to click on one 
of its endpoints and then drag the mouse to where you want the new point to be. 
Remember, if you make a mistake at any time, just choose the Edit > Undo menu 
command. 

Now  going to add a second puff to the cloud. Move your mouse to the point 
just before the end of the previous segment. When the   option for the 
Add Point tool is turned on, the node will turn green when you can automatically 
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weld the new segment to the existing one. When Auto Fill is turned on, the cloud will 
automatically fill with color when the shape is closed. 

 

 

Add a new curve at this point 
 

Click on the second to last point in the curve, and drag down and to the right, as 
shown below. When you use the Add Point tool on a point that is in the middle of a 
curve, what happens is that you start a new curve that is automatically welded to 
that point in the first curve. These two curves are permanently joined at that point, 
which becomes important when we get to filling the shape with color.  what 
your project should look like after adding the new curve segment: 

 

 

A new segment welded to an existing curve 
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Add some points to the end of this new curve to get the shape below. Remember, 
to add a point to the end of a curve, click just on the last point of that curve. 

 

 

More new points 
 

Finally, add two or three more points at the beginning of the original curve. When 
you add the last point, drag it over to the right and line it up with the next to last 
point of the second curve before letting go of the mouse. Moho will automatically 
weld those points together and fill the cloud with color to get the final shape below: 

 

 

Finished cloud 
 

Sometimes it can be hard to follow this sequence of steps -  take a moment to 
watch a movie of the cloud being created in Moho. Pay special attention to where 
the mouse is clicked in order to weld the two curves together. 
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Click this link to view a brief video of how to draw the clouds.. 
 

We will add a line effect to make the cloud a bit softer. In the Style window, check 
the Advanced button to display the advanced style options. Select   from 
the Stroke Effect pop-up menu. Accept the default settings and click OK. 

 

 

Soft Edge effect 
 

Now would be a good time to select the File > Preview command to see what your 
final result looks like: 
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The rendered cloud 
 

A Second Cloud 
 make another cloud. With the Clouds layer selected, choose Edit > 

Select All from the menu. Now choose Edit > Copy, followed by Edit > Paste. 
Next, pick the Transform Points tool from the toolbar. 

In the working area, click and drag to the right to move the new cloud away from 
the original. (When you paste an object from the clipboard, it is positioned directly 
on top of the original.) 

 

 

Duplicated cloud 
 

Use the Transform Points tool to resize this new cloud, making it larger or 
smaller than the original, as preferred (here we make ours larger). 
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The Transform Points tool can resize an object both vertically and horizontally, and 
will scale whether or not the object is selected beforehand. In this case, we  
really want to change the  shape like that. With the Transform Points tool 
active, click and drag one of the corner handles that appears around the cloud, 
thus making it smaller or larger without changing its overall shape. Continue using 
the Transform Points tool until you get the new cloud in a position you like. 

 

 
 

Second cloud scaled and positioned 
 

To deselect all of the points in the cloud, use the Edit > Select None command, or 
press the Enter key, or click outside the cloud to de-select the points. 

Now you can use the Transform Points tool to click and drag individual points to 
reshape the second cloud. 

In this case, since only one point is selected at a time, the Transform Points tool is 
used to re-shape the cloud, not move the entire object. Just re-shape a few points 
here and there so that the two clouds  look exactly the same. 



Quick Start 

22 Moho 12 
Tutorial Manual 

 

 

 
 
 

 
 

Modify some points 
 

Plant a Tree 
Good -  moving right along, but this scene needs some plant life. Add a new 
layer to the project by clicking the new layer button in the Layer window. Again, 
choose  from the popup menu. Name it  

 

 

Rename the layer to Tree 
 

Select a brown fill color from the Style panel. Set Stroke Width to 4, and set the effect 
to <plain>. 
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Select a brown fill color 
 

Using the Add Point tool, along with the welding feature, draw a shape that 
resembles the trunk of a tree. 

Here are a few things to remember as you go: First, you can always use the Edit > 
Undo command to back up if you make a mistake. 

Second, you can switch to using the Transform Points tool to reshape part of 
the object, even if you  finished drawing the whole thing yet. 

Third, the Transform Points tool lets you pick individual points by clicking on them - if 
you want to get rid of a point, but  too far back to use undo, select it with the 
Transform Points tool and press the backspace or delete key on your keyboard. 

Feel free to be creative with your tree trunk, you  really have to stick to the 
sample below. 
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Draw a tree trunk 
 

There are a few tools that may be useful when building your tree that 
 been introduced yet. The Pan Workspace and Zoom 

Workspace tools can be used to move around the workspace. 

Note that these tools are not used to manipulate your drawing - they just let you 
move your view so that you can focus in on a particular area of interest. To reset 
your view to its original position, select the View > Reset command from the menu 
bar. 

Another useful tool is the Curvature tool. Using this tool, you can click and 
drag on a point to adjust how round or pointy the curve is as it passes 

through that point. 
 

 

Use the Curvature tool to adjust the curves 
 

The last thing  add in this tutorial is some greenery to the top of the tree. The 
shape for the treetop will be similar to the clouds, so follow similar steps to create it, 
but there is one tricky part. Because the treetop overlaps the trunk of the tree, it can 
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be easy to click on the wrong part and add a new point to the trunk instead of the 
treetop. 

There are two ways to avoid this problem. 

 One, use the Pan and Zoom tools to move in close to the top of the tree so that 
 easier to avoid clicking on the wrong thing. 

 The second approach is to draw the treetop off to the side where  plenty 
of empty space. Then, when the treetop is finished, drag it back into position at 
the top of the tree. 

 For the second approach, when  ready to move it back into position,  
use the Transform Points tool and click to select one point on the treetop. Then 
use the Edit > Select Connected command to select the rest of the treetop. 
Finally, drag the treetop into place, and use the Transform Points tool to resize it 
if necessary. 

Select a nice leafy green fill color in the Style panel. Set the line width  see 
why later. 
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Select a green fill color and set line width to 4 

 
Use the Add Point tool to draw your treetop.  the kind of look  going for: 
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The treetop 
 

Choose File > Preview to see how the treetop looks. Notice how the ends of line 
segments look kind of squared off and blocky.  fix that using  variable 
line width feature. 

Exit the render window and press Enter to de-select all points in the treetop. 

Now, using the Line Width tool, click on each of the points in the treetop that 
is at the end of a line segment and drag to the left to tapper the endpoint. 
The area that the Line Width tool affects is indicated by a semi-transparent 
red circle. The default width is .5, which is quite large. Decrease the width to 
around .1 or less to obtain finer control over the area that you want to affect. 

 

 
 

Changing line width 
 

Choose File > Preview again, and notice how the endpoints are now nicely tapered. 
This feature  limited to endpoints - experiment with using it on other points along 
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a curve. Also, try dragging the Line Width tool back and forth to make lines thinner 
or thicker. 

 

 
 

The completed background 
 
 

 1.4: Bone  on page 28 will move into using 
bones to control a character, and  

some animation controls to make things move. 
 
 

Tutorial 1.4: Bone Setup 
This tutorial builds on the results of the previous two, teaching you how to add bones 
to a character. You can either continue with the project you created in Tutorial 1.3, 
or you can open a file provided for you named   file can be found 
in the  -  subfolder within your custom content folder. 

Bones are an important tool you can use in Moho to help make animation easier. If 
you think of drawings in Moho (like the ones you made in previous tutorials) as soft 
rubber, then bones can be thought of as stiff wires inside the rubber that help you 
move and position objects. Bones are never displayed in a final 
just used as tools during the animation process. 

Bones are not absolutely necessary for animation. They are very helpful for animating 
certain types of motion as  show in this and the next tutorial, but there are other 
ways to animate in Moho as well. As you gain experience using Moho,  learn 
when bones are appropriate and when  not. 

 

  




